How do I know if my device is compatible with the Baji APP (Android)?

Compatible with devices that use Android version 9.0 and newer. We are constantly working to ensure more devices are fully supported. If you encounter a problem while using the Baji App from your device, please contact our 24/7 customer support team via Live Chat for further assistance.

51420cookie-checkHow do I know if my device is compatible with the Baji APP (Android)?